LDPネイバ確立に必要なこと

スポンサーリンク
Adsense

構成

R1:

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
interface Ethernet0/0
 ip address 10.1.2.1 255.255.255.0
 mpls ip
mpls ldp router-id Loopback0 force

R2:

interface Ethernet0/0
 ip address 10.1.2.2 255.255.255.0
 mpls ip

考慮すべきこと1

  • R1では mpls ldp router-id Loopback0 force を設定しているので、R2は1.1.1.1とLDPネイバ確立しようとする。しかし経路が存在しないのでセッション確立に失敗する。なお、Helloは届いているので相手を見つけることはできている。
R2#show mpls ldp discovery
 Local LDP Identifier:
    10.1.2.2:0
    Discovery Sources:
    Interfaces:
    Ethernet0/0 (ldp): xmit/recv
        LDP Id: 1.1.1.1:0; no route

解決策

結局はLDP Idへ到達可能な/32の経路があればいい。

  • R2から1.1.1.1へ到達可能にすればいい。具体的には ip route 1.1.1.1 255.255.255.255 10.1.2.1 を設定すればよい。
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ip route 1.1.1.1 255.255.255.255 10.1.2.1
R2(config)#end
R2#
*Aug 30 08:02:28.200: %LDP-5-NBRCHG: LDP Neighbor 1.1.1.1:0 (1) is UP
R2#
*Aug 30 08:02:28.881: %SYS-5-CONFIG_I: Configured from console by console
R2#show mpls ldp discovery
 Local LDP Identifier:
    10.1.2.2:0
    Discovery Sources:
    Interfaces:
    Ethernet0/0 (ldp): xmit/recv
        LDP Id: 1.1.1.1:0

考慮すべきこと2

  • R1はR2のLDP Idへのホストルート(/32の経路)が存在しないのでNGに見える
R1#show mpls ldp discovery
 Local LDP Identifier:
    1.1.1.1:0
    Discovery Sources:
    Interfaces:
    Ethernet0/0 (ldp): xmit/recv
        LDP Id: 10.1.2.2:0; no host route

解決策

結局は1と同様にLDP Idへ到達可能な/32の経路があればいい。

  • R1に10.1.2.2/32の経路を登録すれば良い。具体的には ip route 10.1.2.2 255.255.255.255 Ethernet0/0 を設定すればよい。
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ip route 10.1.2.2 255.255.255.255 e0/0
R1(config)#end
*Aug 30 07:55:08.759: %SYS-5-CONFIG_I: Configured from console by console
R1#show mpls ldp discovery
 Local LDP Identifier:
    1.1.1.1:0
    Discovery Sources:
    Interfaces:
    Ethernet0/0 (ldp): xmit/recv
        LDP Id: 10.1.2.2:0
スポンサーリンク
Adsense
Adsense

シェアする

  • このエントリーをはてなブックマークに追加

フォローする